La mise à jour Yoast Métaverse Marketing 19.5 provoque des erreurs fatales

Les éditeurs qui ont mis à jour Yoast Métaverse Marketing 19.5 ont peut-être vécu plus que prévu. Des rapports d’erreurs fatales causées par la mise à jour ont rapidement commencé à faire surface. Fait intéressant, l’erreur semble confinée à des situations spécifiques et non à tous les niveaux.

Yoast Métaverse Marketing version 19.5

La version 19.5 de Yoast contient plusieurs modifications qui améliorent l’expérience utilisateur, corrigent un problème de validation dans les données structurées de l’article et corrigent quelques bogues mineurs.

Une amélioration remarquable est l’inspecteur de référencement frontal qui fournit un aperçu des publications et de divers paramètres de référencement tels que les balises méta et les données structurées.

Malheureusement, un bogue s’est également produit dans une situation spécifique qui a provoqué une erreur fatale.

Une erreur fatale peut se produire lorsqu’il y a un conflit entre deux plugins.

Erreur fatale de levure

Eli Schwartz, expert en Métaverse Marketing de recherche et auteur du livre populaire Product Led Métaverse Marketing, a tweeté à propos d’une erreur fatale.

Il n’est pas rare qu’un conflit aléatoire entre plugins pose problème. Mais ce n’était pas si aléatoire, car d’autres ont confirmé que la même chose leur arrivait.

La page d’assistance officielle de Yoast Métaverse Marketing sur WordPress.org contenait également des rapports d’erreurs fatales.

Lire Plus  Comment utiliser les mots-clés cachés d'Metaverse Marketingverse Marketing pour augmenter la visibilité des produits

Un utilisateur a posté :

Erreur fatale : YoastMétaverse Marketing_Vendor non intercepté

« Je me suis réveillé aujourd’hui et j’ai essayé d’accéder au tableau de bord de mon site Web et j’ai rencontré une erreur fatale, je ne peux pas y accéder via le backend ni la connexion.
Comment puis-je résoudre ce problème.

Deux autres ont répondu avec le même problème, avec l’un d’eux offrant ce commentaire:

« Pareil ici. Impossible de se connecter au backend et le site et le backend génèrent une erreur fatale.

J’ai vu que Yoast s’est mis à jour automatiquement aujourd’hui.

Déplacement de la version gratuite et de la version premium du répertoire des plugins vers un répertoire temporaire et maintenant le site est de retour en ligne.

Quelqu’un d’autre avec la même configuration de la version gratuite et premium fait écho à ce rapport, en publiant:

“Obtenir une erreur fatale après la mise à jour aussi. Ayez également la version gratuite, la version premium et News Métaverse Marketing.”

La personne de soutien officielle de Yoast s’est excusée, répondre avec cette déclaration:

« Nous sommes désolés que vous rencontriez une erreur fatale. Merci pour le signalement.

Nous enquêtons et il semble y avoir un problème avec la dernière mise à jour de Yoast Métaverse Marketing alors que la plus récente Premium n’est pas encore sortie. Cela n’aurait pas dû arriver.

Nous cherchons à résoudre ce problème dès que possible en publiant un correctif gratuitement et également en publiant Yoast Métaverse Marketing Premium dès que possible.

L’un ou l’autre devrait corriger l’erreur fatale.

Yoast répond

Joost de Valk, le fondateur de Yoast, a fait part de ses commentaires au Search Engine Journal :

« Un patch a été créé rapidement par l’équipe en effet et pour la plupart des sites qui l’ont entièrement résolu.

Pour certains sites, le mécanisme de mise à jour automatique n’a pas fonctionné correctement et, par conséquent, ces sites ne se sont pas automatiquement corrigés.

Nous en avons beaucoup discuté en interne, car nous n’étions pas du tout contents que cela se produise, et nous n’étions pas satisfaits de la façon dont nous l’avons géré. Honnêtement, nous sommes tous vraiment déçus et nous sommes désolés pour les sites que nous avons cassés.

Yoast identifie le problème

Le dernier commentateur qui a noté qu’ils avaient installé deux versions du plugin Yoast, les versions gratuite et premium, peut avoir été un indice de ce qui a causé la faille fatale, car cette situation a été citée comme la raison pour laquelle l’erreur fatale se produisait.

Lire Plus  Référencement local pour les cabinets d'avocats : obtenez plus de clients locaux

Yoast a répondu rapidement aux problèmes et a publié un correctif le jour même, la version 19.5.1.

Selon le Journal des modifications du plugin Yoast Métaverse Marketing WordPress qui documente le contenu de chaque mise à jour :

« 19.5.1 – Corrections de bogues :

Corrige un bogue où une erreur fatale était générée sur le front-end lorsque Yoast Métaverse Marketing 19.5 était utilisé avec une ancienne version de Yoast Métaverse Marketing Premium.

Le problème est résolu avec la version 19.5.1

Yoast 19.5.1 a résolu le problème.

Une l’utilisateur a posté ce commentaire dans le forum d’assistance Yoast :

« La mise à jour 19.5.1 a corrigé le problème. »

Cependant, comme il y a des millions d’utilisateurs avec des millions de combinaisons d’autres plugins installés, il est presque inévitable que très peu de cas marginaux puissent survenir avec des problèmes.

Par exemple, dans un message du forum de support officiel de Yoast, un utilisateur décrit mise à jour de 19.4 directement à 19.5.1 et n’ayant pas une expérience satisfaisante.

Ils ont partagé:

« Je suis passé de 19.4 à 19.5.1 et ça a quand même cassé mon site. Je ne pense pas que .5.1 ait résolu tout le problème. Je n’ai jamais mis à jour vers 19.5. Passé directement du 19.4 au 19.5.1.
J’ai du yoast, du yoast premium et du woo. tous les 3. Tout d’abord, celui à essayer de mettre à jour était le yoast régulier. Tous les autres plugins et WP sur mon site sont à jour. J’espère que cela aide à réparer 19.5.1

Heureux de ne jamais faire confiance à la mise à jour automatique, je ne suis pas fan de payer quelqu’un pour être un testeur bêta.

Pourtant, celui-ci m’a toujours eu.

Il n’est pas inhabituel que des cas marginaux apparaissent pour toute mise à jour, et cela pourrait être le cas pour Yoast 19.5.1.

Lire Plus  Points de vue du PDG de Rank Ranger, Shay Harel

La cause du problème semble être que Yoast a publié une mise à jour pour la version gratuite de Yoast (19.5) mais n’a pas publié simultanément une mise à jour de la version premium, ce qui a ensuite provoqué un conflit entre les deux plugins, entraînant une erreur fatale.


Image sélectionnée par Shutterstock/Kues